dnsmasq + IPv6: unsupported configuration

Manchmal, aber wirklich nur manchmal könnte ich diesen ganzen IT-Kram aus dem Fenster werfen! Vor allem dann, wenn ich bemüht bin, meine Systeme auf einem aktuellen Stand zu halten und mir dann Updates nichts als Ärger bringen. Dann denke ich gern an meinen SEO- und PHP-Guru Michael, der mich immer mal wieder gern damit aufzieht.

Was war es diesmal?

TestbildEiner meiner bei Hetzner gehosteten Server läuft mit openSUSE 12.2 und stellt über KVM einige virtuelle Maschinen bereit, die ich u.a. für Websites und Datenbanken nutze. Ich versuche, die Uptime möglichst groß zu halten, um Ranking-Abstiege bei Google durch Downtimes zu vermeiden. Doch regelmäßig schreit openSUSE nach einem Update, da diverse neue Paketversionen zur Verfügung stehen. Da mich Nagios auch brav regelmäßig per Mail informiert, sorge ich dann auch relativ zeitnah für die Durchführung. weiterlesen →

404-Fehler nach Update auf WordPress 3.1.2

Ärgerlich! So ganz nebenbei hatte ich heute meine WordPress-MultiSite-Umgebung automatisch auf die neu veröffentlichte Version 3.1.2 aktualisiert. „Alle Blogs im Netzwerk aktualisieren“ hatte ich ebenfalls ausgeführt. Als kleine Stichprobe für die erfolgreich verlaufene Prozedur genügte mir der Aufruf der Startseite eines meiner Blogs. Das sollte sich heute noch als grober Schnitzer herausstellen.

Ich bemerkte eher zufällig, dass das Aufrufen beliebiger Artikel und Kategorien-Seiten bloß noch in 404-Fehlern endete… weiterlesen →

Tastatur-Probleme mit FreeNX

Es ist ein merkwürdiges Phänomen: Wenn ich mich von meinem Linux-Client (openSUSE 11.2) mit dem NX-Client von NoMachine (Version 3.4.0-5) zum FreeNX-Server (openSUSE 11.2, FreeNX 0.7.2) verbinde, fehlen mir bestimmte Key-Mappings. Bild-auf-/Bild-ab-Taste, Pfeiltasten und Tasten wie „Entf“, „Pos1“ usw. zeigen entweder keine Reaktion oder schlicht etwas völlig falsches. weiterlesen →

Fehlerhafte Passwort-Verschlüsselung bei openSUSE 11.0

Bei meinen installierten SuSE-Linux Systemen verwende ich überwiegend MD5 zur Passwortverschlüsselung. Seit openSUSE 11.0 schien dies allerdings nicht mehr korrekt zu funktionieren. Ich habe MD5 ausgewählt, aber nur DES bekommen. Keine Reaktion auf meine Anfrage im UseNet. Quasi auch keine Reaktion in den openSUSE-Foren. Also habe ich einen Bug-Request bei Novell eröffnet. Und siehe da! Es klappt. Dort wurde mein Request binnen weniger Tage bearbeitet und gelöst. Es wurden ein Patch und ein Security-Announcement veröffentlicht (CVE-2008-3188).